iPhoneでSoftetherVPNにL2TP/IPsecで接続できない

SoftEther VPN に関するご質問はこのフォーラムにお気軽にご投稿ください。
Post Reply
Ueno
Posts: 2
Joined: Thu Jan 09, 2014 3:22 am

iPhoneでSoftetherVPNにL2TP/IPsecで接続できない

Post by Ueno » Thu Jan 09, 2014 3:38 am

よろしくお願いいたします。
自宅のルータ(バッファローのWZR-HP-AG300H)にSoftEtherVPNサーバの最新版をインストールたノートPC(WindowsXP)を有線LANで接続しております。

外部からPCにインストールしたSoftEtherクライアントによる接続はできておりますが、
iPhone5(iOS7.0.4)でL2TP/IPsecによる接続ができません。

iPhoneで接続を試みると、しばらくしてから
”L2TP-VPNサーバが応答しませんでした。もう一度接続してください。それでも問題が解決しない場合は、設定を確認し、管理者に問い合わせてください。”
というメッセージが表示されます。

なお、同一のiPhoneを上記ルータのWIFIにつなぎ、ノートPCのローカルIPをサーバに設定して接続すると、問題なく接続できます。

したがってルータの設定に問題があると思うのですが、ポート設定については、SoftEtherのサイトの記述に従い、ポート変換(ポートマッピング)でUDP4500,UDP500をノートPCのローカルIPアドレス宛になるように設定しております。

こちらの記事
http://www.teradas.net/archives/11338/
によると、

UDP 1701(L2TPトンネル用)
ESP(プロトコル番号 50)
UDP 500
UDP 4500(NATトラバーサル用)

もポートマッピングの設定をする必要があるということです。
が、SoftEther様の問い合わせからのご返答では、
”SoftEther VPN の L2TP/IPsec ではUDP/500 と UDP/4500 しか使用しません。”

とのことでした。

なお外部のPCによるSoftEtherクライアントによる接続では、ポート6001を使用しており、TCP 6001をポート変換設定しております。

ご教示いただければ幸いです。

hiroshi
Posts: 129
Joined: Tue Mar 19, 2013 5:07 pm

Re: iPhoneでSoftetherVPNにL2TP/IPsecで接続できない

Post by hiroshi » Thu Jan 09, 2014 6:10 am

Uenoさん こんにちは~

かなり古いものですが^^;
自宅にあった「バッファローWZR-RS-G54」で試してみました。
このルータは「VPNマルチパススルー(PPTP/IPSec)」に対応しています。
http://buffalo.jp/products/catalog/item ... tml?p=spec

必要なポートとともに、ESP(プロトコル番号50)をVPNサーバへ転送設定したところ接続可能となり
ESPの転送設定を外すと接続出来ませんでした。

バッファローのWZR-HP-AG300Hは仕様によるとPPTPのみでIPSecには対応してないように思われます。
http://buffalo.jp/products/catalog/netw ... 300h/#spec

ファームウェアのアップデート等で対応になっているかも知れませんので
一度メーカーに確認されては如何でしょうか?

Ueno
Posts: 2
Joined: Thu Jan 09, 2014 3:22 am

Re: iPhoneでSoftetherVPNにL2TP/IPsecで接続できない

Post by Ueno » Wed Jan 22, 2014 2:27 am

hiroshi様

ありがとうございます。
ファームウェアをアップデートしましたが、やはりIPSecには対応していないようでした。
代わりに、SoftEtherVPNサーバでOpenVPNを有効にし、iphoneのOpenVPNというアプリで接続することができたので、ひとまずこちらで代替することにいたしました。
ありがとうございました。

hiroshi wrote:
> Uenoさん こんにちは~
>
> かなり古いものですが^^;
> 自宅にあった「バッファローWZR-RS-G54」で試してみました。
> このルータは「VPNマルチパススルー(PPTP/IPSec)」に対応しています。
> http://buffalo.jp/products/catalog/item ... tml?p=spec
>
> 必要なポートとともに、ESP(プロトコル番号50)をVPNサーバへ転送設定したところ接続可能となり
> ESPの転送設定を外すと接続出来ませんでした。
>
> バッファローのWZR-HP-AG300Hは仕様によるとPPTPのみでIPSecには対応してないように思われます。
> http://buffalo.jp/products/catalog/netw ... 300h/#spec
>
> ファームウェアのアップデート等で対応になっているかも知れませんので
> 一度メーカーに確認されては如何でしょうか?

Post Reply