It is currently Sun Jun 25, 2017 10:32 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: l2tp problem
PostPosted: Sat Jun 10, 2017 3:28 pm 

Joined: Sat Jun 10, 2017 2:55 pm
Posts: 3
hi, i'm use softether on ubuntu 16.04.02, odroid xu3(similar rpi)

openvpn work fine, but l2tp is the problem on both desktop and android phone.

On windows desktop, i can't connect vpn server using l2tp
720 error(A connection to the remote computer could not be established. You might need to change the network settings for this connection) has occured. As you can see the log file, A PPP protocol error occurred, or the PPP session has been disconnected.

On android smart phone, connection is successful, lock icon is shown. but internet isn't work(browser alarm that 'can't find dns address'.) on the log file, program just try to create udp session.

what should i do?


Attachments:
virtual_nat setting.png
virtual_nat setting.png [ 29.8 KiB | Viewed 395 times ]
l2tp logs2.txt [8.55 KiB]
Downloaded 17 times
l2tp logs1.txt [5.47 KiB]
Downloaded 17 times
Top
 Profile  
Reply with quote  
 Post subject: Re: l2tp problem
PostPosted: Sat Jun 10, 2017 5:31 pm 

Joined: Tue May 23, 2017 11:53 am
Posts: 10
Try setting DNS server 1 to 8.8.8.8
and leave DNS server 2 blank and see if that works (168.126.63.1 is a valid DNS server as well, but I am not sure if any DNS service is running in the VPN server).

Also try installing a console application on your mobile and see if you can ping to any remote ip, and also check the default route.


Top
 Profile  
Reply with quote  
 Post subject: Re: l2tp problem
PostPosted: Sun Jun 11, 2017 6:51 am 

Joined: Sat Jun 10, 2017 2:55 pm
Posts: 3
i follow your order. but problem is still remain.
On smart phone console, it can ping any ip address but can not ping any dns name(url). example) can ping 8.8.8.8, but can't ping www.google.com
i guess vpnserver couldn't received the data from dns server.


Top
 Profile  
Reply with quote  
 Post subject: Re: l2tp problem
PostPosted: Thu Jun 22, 2017 6:45 am 

Joined: Mon Feb 24, 2014 11:03 am
Posts: 2175
Did you configure that the Android uses the VPN as default gateway?
http://www.softether.org/4-docs/2-howto ... ient_Setup


Top
 Profile  
Reply with quote  
 Post subject: Re: l2tp problem
PostPosted: Fri Jun 23, 2017 10:00 am 

Joined: Sat Jun 10, 2017 2:55 pm
Posts: 3
Are you talking about 'Forwarding routes' field?
I entered 0.0.0.0/0, but nothing is changed.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Return to www.softether.org