Help: Error Code 2

Post your questions about VPN Gate Academic Experiment Service here. Please answer questions if you can afford.
Post Reply
LordBadon
Posts: 6
Joined: Wed Sep 17, 2014 9:32 pm

Help: Error Code 2

Post by LordBadon » Wed Sep 17, 2014 9:45 pm

Hi, I am running the latest version of SoftEther VPN Client on my Windows 8 PC. It was working fine until about a week ago when I started getting an error saying this:

"Error (Error Code 2):
Protocol error occurred. Error was returned from the destination server."

I have ran the application as an administrator and I still get the error. I have tried allowing SoftEther access to port 443 in my firewall settings and I still get the error. I have tried reinstalling and I still get the error.

I checked my network activity in Kaspersky and closed all applications using port 443 other than SoftEther (in this case, I closed Skype, LINE, Flash, and FireFox). I still got the error.

The only thing that seems to allow me to connect to a VPN is using UDP instead of TCP, and even that only allows the connection to last 5 minutes before I am suddenly disconnected for no apparent reason at all.

At this point I am at a loss, I don't know what else to try. Could anybody help me?

vulchor
Posts: 4
Joined: Wed Jun 25, 2014 6:19 am

Re: Help: Error Code 2

Post by vulchor » Sun Oct 26, 2014 1:52 am

I've had this problem too for a couple months now. On many servers, UDP is the only connection that goes through. I had never had a problem getting kicked when connected as UDP until last night. That connection lasted about 5 minutes, as you said.

Try other servers if you can, hopefully it was just coincidental that you got booted after 5 minutes, because I've had long-running success using UDP on the servers that I use. Otherwise, I get error 2. Hopefully someday soon someone will come up with a solution, or even an explanation.

BoredAus
Posts: 115
Joined: Sun Nov 23, 2014 3:29 am

Re: Help: Error Code 2

Post by BoredAus » Sun Nov 23, 2014 4:27 am

Theres no simple solutions for issues like these. Probably the best way is to disable all firewalls temporary at first and then see if the connection is stable via TCP without firewalls enabled. Then slowly work your way enabling firewalls and all one by one to see which one is that is blocking TCP connection.

In most cases I would personally say that either a poor and/or congested network between you and the VPN server could be at fault once you have disabled all firewalls on your end that you have access to and you still cannot maintain a reliable connection via TCP. A TCP is much more demanding connection method than UDP as it has checksum ability as well as other things that UDP normally omits, the situation worsens when you are connecting from either a poor country and/or on networks that are heavily congested.

If you have ran traceroute, make sure that the latency between your connection and the VPN server is not high and that you have tried other VPN servers. If you have tried a lot of other VPN servers including from countries that you normally wouldn't connect through and you are getting the same issue over TCP I would dare say it is generally an issue with heavy congestion that is on your end. You can also try connecting at the off peak hours of the day to also make sure that it is not to do with congestion on your end. Poor connectivity cannot be easily solved but it usually starts with understanding your connectivity with the internet as a whole. The easiest way would be to switch between carriers/ISP but that is not a guaranteed method. If you are going through wireless connections, try going through wired first.

betsyjolas
Posts: 1
Joined: Mon Jun 06, 2022 3:38 am

Re: Help: Error Code 2

Post by betsyjolas » Mon Jun 06, 2022 3:47 am

I have read the article about how to troubleshoot protocol errors in SoftEther VPN. And after following the steps I was able to get SoftEther VPN Client working again.

The solution was simple: Go to Control Panel > Network and Sharing Center > Change adapter settings > Right-click on Ethernet connection > Properties > wordleUnder Local Area Connection Properties, click on Internet Protocol Version 4 (TCP/IPv4) tab. Click on Properties button next to Use the following IP address range. Enter an alternative static IP address of your PC with subnet mask of 255.255.255.0. Then checkmark Use a DNS server other than my computer and Save changes button below it. Internet should now be working as expected without any further error messages or message boxes being displayed.

Post Reply