Authentication “Access denied”

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 1
Joined: Mon Mar 02, 2020 9:28 am

Authentication “Access denied”

Post by ruvonuwo » Mon Mar 02, 2020 10:52 am

I'm using SoftEther APIs to connect to a VPS and then try to build a VPN on that . I can successfully connect to server using IP and Port, then at Authentication step I get "Access denied" and no more details. The authentication step is using Password and HubName.

I've read the APIs codes deeply and I realized it using SHA0 algorithm to encrypt password and take a random arrays of bytes from server and use that as salt in encrypt method . So I've changed the encryption method at SoftEther Application to AES128 , AES256 and some others but the result has not been changed at all. I also tried to send password as an ASCII but none of them worked.

The exact API code without change:

Code: Select all

using (var softEther = new SoftEther(ip, port))
    // the connection step that would pass successfully :           
    var connectResult = softEther.Connect();
    if (!connectResult.Valid())

// the Authentication step that got problem :            
    var authResult = softEther.Authenticate(pw, hubName);
    if (!authResult.Valid())

    // the code stops and don't get here :           
    var user = softEther.HubApi.GetUser(hubName, userName);
    Console.WriteLine(user.Valid() ? "Success" : 
upd. Thanks !
Last edited by ruvonuwo on Thu Apr 30, 2020 7:25 am, edited 2 times in total.

Posts: 22
Joined: Fri Mar 13, 2020 11:33 pm

Re: Authentication “Access denied”

Post by ddunston » Sun Mar 15, 2020 2:16 am

I'm not sure if you've resolved this or not. Have you checked the detailed logs that Softether creates to see if it is providing additional information that can help troubleshoot this problem?

Post Reply