Softether and MacOSX - DHCP issues

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
Posts: 1
Joined: Thu Mar 19, 2020 1:34 am

Softether and MacOSX - DHCP issues

Post by roxon » Thu Mar 19, 2020 1:42 am


I tried to setup Softether on a Windows 10 Computer as Server using L2TP VPN over IPSEC, which overall seems to work, but not completely as intended
- Using another Windows Computer along with the SoftEther Client I can successfully connect to the VPN Server
- Using a MacOSX Laptop I can connect to the Server at the first attemp. If I disconnect once from the Network I can't reconnect again. (After I restart the VPN Server i can then reconnect again)

I enabled the SecureNAT function, which might be part of the issue.

When I connect to the VPN Server via the local IP while being in the same Network my macOSX pulls an IP from Softether ( for example)
At the same time the WIFI Module of the MacOSX gets another IP address of the SecureNAT Application (

Again, after a reboot of the Server I can reconnect to the VPN Server again. Should I turn off DHCP and enable static IP to avoid the IP issues?

Also: When I connect via the Windows Client it only works when NAT-Traversal is enabled. As soon as I disable NAT Traversal I'm no longer able to connect to the VPN, even though this is a home network, so there is no firewalls in between or something

Thank you very much for your help

Posts: 1
Joined: Mon Mar 23, 2020 7:10 am

Re: Softether and MacOSX - DHCP issues

Post by caseycollier » Mon Mar 23, 2020 7:13 am

Same here, I tried different ways but sill has a issue
8 ball pool download for pc

Post Reply