Streaming media

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
GeorgeKaplan
Posts: 2
Joined: Tue Feb 13, 2024 2:08 pm

Streaming media

Post by GeorgeKaplan » Sat Feb 24, 2024 7:35 am

I have a SoftEther set up on my home PC with SecureNAT enabled.

Everything works fine as regards to connecting via my client laptop (with NAT-T disabled), so that it can use my home LAN, Internet, etc.

The one problem I have is this:

I have Media portal 2.5 server installed on my home PC and want to stream live TV to my client.

The server and client media portal can see each other and connect. Everything works fine up until the point where I select a channel to watch.

My client laptop has been given the ip address: 192.168.30.10 by SoftEther's DHCP.

However, media portal tries to send the video stream to 192.168.1.12 which is the address of the SecureNAT (as it shows up on my home router).
Is there any way I can configure SoftEther to forward any stream from 192.168.1.12 to my client 192.168.30.10?

I used to be able to stream TV using an older version of SoftEther, but since I upgraded to the latest one, I’ve had this problem.

I am having the same problem with Universal Media Server not streaming media.

Also, Softether does not work unless I enable SecureNAT.

I only have a basic knowledge of networking, so if you can help, please keep answers straightforward.

solo
Posts: 1347
Joined: Sun Feb 14, 2021 10:31 am

Re: Streaming media

Post by solo » Sat Feb 24, 2024 11:02 am

GeorgeKaplan wrote:
Sat Feb 24, 2024 7:35 am
I have a SoftEther set up on my home PC with SecureNAT enabled.
...
I have Media portal 2.5 server installed on my home PC
As both SE server and the portal are on the same PC, install there also SE client and connect it to "localhost" using static IP 192.168.30.2 w/o default gateway. Then after establishing remote VPN connection use the address for streaming. Alternatively, drop SecureNAT and bridge the hub.

GeorgeKaplan
Posts: 2
Joined: Tue Feb 13, 2024 2:08 pm

Re: Streaming media

Post by GeorgeKaplan » Sat Feb 24, 2024 7:00 pm

I didn't really understand the first suggestion, but I tried the second one: disabled SecureNAT and established a local bridge - and it worked.

Thanks a lot. Much appreciated.

Post Reply