Some traffic is not going through the VPN

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
zimbam
Posts: 2
Joined: Wed Apr 03, 2024 2:33 pm

Some traffic is not going through the VPN

Post by zimbam » Wed Apr 03, 2024 2:38 pm

I'm stuck in a restrictive network and trying to solve the problem with a VPN. I've set up a SoftEther VPN server on a Linux cloud machine, and I'm running SoftEther VPN client on Windows locally from within the restricted network.

Some of my traffic is not being routed through the VPN. Examples include ssh traffic and a UDP application.
Some of the traffic IS making it through, though, because websites that were blocked on my restrictive network are now available.

I adjusted the Windows network metric on both interfaces to give the VPN interface a higher priority (10 for the VPN, 20 for the local connection). That may be what enabled the web traffic to get through, but it doesn't seem to have fixed the problem for ssh or UDP.

I don't think I've changed anything in the advanced settings in the SoftEther VPN client for my network connection. No Adjustments of Routing Table is still unchecked. I haven't added or changed any routes from the command line.

Any ideas how to get all my traffic to go through the VPN, or at least these specific cases?

zimbam
Posts: 2
Joined: Wed Apr 03, 2024 2:33 pm

Re: Some traffic is not going through the VPN

Post by zimbam » Wed Apr 03, 2024 8:16 pm

Based on this other thread, on my server I made sure I had no bridges, and ran SecureNATEnable, but nothing has changed. ssh traffic is still not routed through the VPN on my client machine.

solo
Posts: 1347
Joined: Sun Feb 14, 2021 10:31 am

Re: Some traffic is not going through the VPN

Post by solo » Wed Apr 03, 2024 10:55 pm

Disable the SSDP Discovery service, reboot and re-try. If still problematic, start the VPN and post AS CODE from the client:

Code: Select all

netstat -r
ipconfig /all

Post Reply