issue of VPN connection dropping in idle mode or when not using the mobile

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
sahar_talabi
Posts: 2
Joined: Thu Apr 11, 2024 5:13 pm

issue of VPN connection dropping in idle mode or when not using the mobile

Post by sahar_talabi » Thu Apr 11, 2024 5:46 pm

Hello,
I have installed and set up SoftEther. I have tried both the OpenVPN and SSTP methods. I have this problem on my mobile device. When I lock the phone and unlock it after one to two hours, the internet connection is disconnected. Although the connection status appears to be connected on OpenVPN, I have no internet connection. In other words, the VPN connection is dropped.

I tried to solve this problem in two ways. First, I enabled the 'use keep alive internet connection' option, but the problem persists. I also tried adding the 'keep alive 10 60' command inside the OpenVPN config, but it didn't solve the issue.

When I encountered the same problem with SSTP, I realized that the config output is fine, and the problem must lie in the SoftEther configuration installed on the server. But I couldn't find the problem.

What solutions do you suggest for this problem?

Image
Image
Image

solo
Posts: 1349
Joined: Sun Feb 14, 2021 10:31 am

Re: issue of VPN connection dropping in idle mode or when not using the mobile

Post by solo » Fri Apr 12, 2024 2:30 am

On your phone exclude the VPN app from optimization on both battery and data.

sahar_talabi
Posts: 2
Joined: Thu Apr 11, 2024 5:13 pm

Re: issue of VPN connection dropping in idle mode or when not using the mobile

Post by sahar_talabi » Fri Apr 12, 2024 5:55 am

solo wrote:
Fri Apr 12, 2024 2:30 am
On your phone exclude the VPN app from optimization on both battery and data.
I tested this on 10 different phone models. When I tested configurations from others who had binaries other than SoftEther, such as the original OpenVPN binary, I didn't encounter any issues. However, despite the SoftEther output showing no problems, there seems to be an issue within the underlying structure of the configuration or the settings of SoftEther itself that I'm unaware of how to address.

solo
Posts: 1349
Joined: Sun Feb 14, 2021 10:31 am

Re: issue of VPN connection dropping in idle mode or when not using the mobile

Post by solo » Fri Apr 12, 2024 8:29 am

It does not matter how many different phone models you had tested as by default they do not "exclude the VPN app from optimization on both battery and data". Do so and then test it. While at it, switch to a different internet connection for another test.

In short, it has nothing to do with SoftEther.

Post Reply