SoftEther client within Linux Deploy

Post your questions about SoftEther VPN software here. Please answer questions if you can afford.
Post Reply
forestDwelr
Posts: 2
Joined: Fri Mar 15, 2019 8:45 am

SoftEther client within Linux Deploy

Post by forestDwelr » Fri Mar 15, 2019 9:06 am

I am running ubuntu bionic under Linux Deploy on Android nougat (Tegra K1 chipset). I have built softether from source and the compile/config & client connection startup show no errors. However, although connection seems to succeed i am unable to access the vpn network (can still see local network & internet) ...
1. Is there some fundamental reason why this can't work?
2. If not, how to debug?

Other info:
-For reference, i have a native ubuntu bionic install on a laptop (on the same network), which connects just fine. Softether version and NIC/account setup are identical between the two. 'ifconfig' output of running NIC is identical. netstat output looks identical for vpnclient entries (except for differences in dynamically assigned port numbers). List of installed cyphers is also identical.
-No firewall on either ubuntu or android host.

forestDwelr
Posts: 2
Joined: Fri Mar 15, 2019 8:45 am

Re: SoftEther client within Linux Deploy

Post by forestDwelr » Fri Mar 15, 2019 3:09 pm

One more comment:

Reading around other posts related to VM's etc it looks like making a bridge between softether and the dummy device setup by linux deploy would be a good place to start. However, when i tried to do this it fails because the kernel is compiled without CONFIG_BRIDGE.
It's probably not worthwhile to try and recompile the kernel (especially just as a guess) - any non-bridge ideas?

Post Reply